Logging file not working

Jul 17, 2015 at 9:29 PM
After installation, I cant see the log file being created in the logging directory. I tried all the steps mentioned, and tried to edit work items but nothing shows up in the logging directory.

The log files should populate automatically, correct? I am using 2013.4...Any ideas from the authors? Thanks!
Jul 24, 2015 at 7:50 AM
The two main reasons for this behavior are

a) wrong version of TFS Event Workflows
a wrong version simply results in a load error of the plugin assembly

b) access rights to the logging directory
check whether the log file path provided in the .config exists
check whether the "TFS app pool service account" and/or the "TFSJobAgent service account" have access to this directory
Jul 30, 2015 at 7:37 PM
Thank you, the logging file now works. There is one error that shows up in the logs, not sure how it affects the functioning..The error is,
Microsoft.TeamFoundation.TeamFoundationServerUnauthorizedException: TF30063: You are not authorized to access... ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized.

Not sure which account it is referring to. Any ideas? Thanks!
Aug 6, 2015 at 8:02 PM
TFS Event Workflows are executed under the TFS service account. At startup TFS Event Workflows access TFS using the client object model. So it seems that in your configuration the service account has no right to access itself using the Client API. Uncommon, but possible. Can you post Information about your configuration, especially regarding the service account.
Aug 6, 2015 at 9:24 PM
Edited Aug 10, 2015 at 8:20 PM
I think I found what the issue was. Like you mentioned, the Service Account did not have access to the TFS Collection.

I was working on creating a TFS Server side plugin and found similar access issue. TEW also might have failed because of this. Thanks!